Email Deliverability Degraded

Incident Report for Arkestro

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 08, 2026 - 21:23 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 08, 2026 - 21:23 UTC

Investigating

Arkestro's Corporate and Platform email delivery systems are currently degraded. Approximately less than ~3.6% of email is being rejected for SPAM reasons.

We are working with relevant third parties to resolve this.

We will post status updates daily or as new information is available and when the issue is resolved.
Posted Sep 03, 2026 - 16:00 UTC
This incident affects: Platform notification email and Corporate email (arkestro.com).